件名: Ver1.8?->Ver2.0 テーマは事前に変更する必要がありますか?

投稿日: 06/30/13 04:04 PM JST
投稿者: yoshiro

上記バージョンアップを進めるに際し、ダウンロードサイトの注意書きに、「テーマはあらかじめ2.0.0のテーマにアップグレードしておいた上で、/admin/install.php を実行してください。」との記述があります。 事前にテーマだけをver2.0対応のテーマにしてからインストールを開始する必要があるという意味でしょうか? (そもそもVer1.8?上にVer2 用のテーマはインストールできるのでしょうか?)ご教授いただければ幸いです。 何度か、バージョンアップの際に失敗したことがありお聞きする次第です。 よろしくお願いします。

書込: Ver1.8?->Ver2.0 テーマは事前に変更する必要がありますか?

投稿日: 06/30/13 04:24 PM JST
投稿者: Ivy

アップグレードの際に、まずバックアップしたあと、Geeklog 2.0.0のソースをすべてサーバーにアップロードすることになりますが、
その際、テーマを、デフォルトで提供したテーマでない場合には、テーマのファイルが上書きされませんので、そのため、テーマはバックアップをとったうえで、2.0.0で提供しているテーマのファイルで上書きしてください。

その際、2.0.0からは、functions.phpの5つのファイルの関数名に、テーマ名が使われるようになっていますので、functions.phpをかならず編集してください。

書込: Ver1.8?->Ver2.0 テーマは事前に変更する必要がありますか?

投稿日: 06/30/13 04:28 PM JST
投稿者: Ivy

professional_cssベースからdenimへの変更は、そうむずかしくないですので、レスポンシブWEBデザイン、ぜひご活用ください。

書込: Ver1.8?->Ver2.0 テーマは事前に変更する必要がありますか?

投稿日: 06/30/13 05:02 PM JST
投稿者: yoshiro

早速のアドバイスありがとうございました。 つまり、(旧バージョン1.8?)標準のテーマをそのまま使えば特にテーマを先にバージョンアップする必要は無いとでよろしいでしょうか? 

書込: Ver1.8?->Ver2.0 テーマは事前に変更する必要がありますか?

投稿日: 06/30/13 05:08 PM JST
投稿者: Ivy

たとえばprofessional_cssのテーマを、テーマ名を変更しないで使っていた場合、Geeklog 2.0.0のソースを上書きしたら、テーマも上書きされるので、別途テーマのファイルを上書きする必要はない、ということです。

書込: Ver1.8?->Ver2.0 テーマは事前に変更する必要がありますか?

投稿日: 06/30/13 05:14 PM JST
投稿者: yoshiro

ご確認ありがとうございました。最後までアドバイスいただき感謝しています。

Geeklog Japan - 掲示板
https://www.geeklog.jp/forum/viewtopic.php?showtopic=17902