件名: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/06/29 07:46
投稿者: nuiito3

1.7.0→1.8.1へのアップグレードの際に。

インストーラーを立ち上げ、db_config.phpのパスを入れた後、アップグレードを選択したら
「無効なモードが指定されました。」
となり、前へ進むことが出来ません。
考えられる原因と、出来れば解決方法を教えていただければありがたいです。
よろしくお願いいたします。

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/06/29 12:25
投稿者: terayama

geeklog-2.2.1sr1 のコード中に
無効なモードが指定されました
を見つけれらませんでした
バージョンはいくつでしょうか

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/06/29 16:53
投稿者: nuiito3

スミマセン、間違えていました。
1.7.0→1.8.2sr1 です。

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/06/30 11:50
投稿者: terayama

初めの1行目にありましたね ごめんなさい
admin\install\index.php にある
$display .= '<p>' . $LANG_INSTALL[100] . '</p>' . LB;
が出しているのかな
その前あたりに
var_dump($_GET);
仕込んで探すくらいしか思いつきません

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/06/30 23:33
投稿者: nuiito3

terayamaさん、いつもありがとうございます!

php、全くわからず動こうとしています。
久しぶりにここへ来て、過去ログをあちこち見るうちに感じたのは
「世の中のプログラミングに関する知識が確実に底上げされている」
ということ。
小学生からプログラミングの授業があるので当たり前なことなんですが。
自らのレベルも上げないと埒あかないなぁと実感しています。
あ、無駄話でした、スミマセン。 Smile

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/07/01 08:40
投稿者: terayama

1.元データベースと素のGeeklogでセット 最後までアップデートする
2.拡張部分を追加する
3.画像とかを追加する
私ならこうするかな

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/07/01 08:46
投稿者: terayama

拡張部分も一回であげれないのだったら難しいのか・・・
悩ましいですね

書込: アップグレードの際に「無効なモードが指定されました。」

投稿日: 2022/07/01 23:38
投稿者: nuiito3

わかりやすいシンプルなアドバイス、ありがとうございます。
素のGeeklogサイトにデータベースを合わせる、、、私にできるか否かは別にして(笑)カスタマイズが少ないサイトならばその方がわかりやすいのかもしれませんね。
他サイトでの同じアップグレードでは躓きがなかったので、ひょっとしたらファイルのアップロードが完璧ではなかったのかも?と思い、もう一度アップロードし直そうかと思いましたが、今はサイト、落ち着いています。
お騒がせいたしました‍♀️‍♀️‍♀️

Geeklog Japan - 掲示板
https://www.geeklog.jp/forum/viewtopic.php?showtopic=19811