2019/11/17 21:58 JST

Geeklog Japan Forums

メディアギャラリーの使い方

ページナビゲーション


状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 59
メディアギャラリーが複雑で使い方が分かりにくいのですが、
インストール後に使用できるサンプルページまたはデモページは存在しないのでしょうか?
https://www.geeklog.jp/mediagallery/album.php?aid=10
のページのようなアウトプットを得るには何を設定していったらいいのでしょうか?
アルバムを作成すると対応するmedialistの番号ができるのでしょうか?

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5932
場所:Tokyo
https://demo.geeklog.jp/mediagallery/album.php?aid=1&page=1
こちらをどうぞ。
メディアギャラリーでつかえる自動タグやサンプルがすべて表示されています。

medialistの番号は、URLをみていただくと、aid=1 とあれば、アルバムIDは1です。
ページにも、1花 というふうに、ID アルバム名 と表示されます。

主な自動タグmedialistの詳しい使い方はアルバムのページの下に表示されます。

このテンプレートは最近更新しています。もしこの表示にならないようなら、再度ダウンロードしてみてください。
MediaGalleryのプラグインを差し替えてください。

状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 59
質問1.シンプルに、画像を1枚ずつスライドショーで表示するにはどうしたらいいでしょうか?
fslideshowというのを試そうとしましたが、使い方(仕様)もわからず、うまくいきませんでした。
試した方法は
静的ページを新規作成で、ページのタイトルに、スライドショーテスト、内容に
PHP Formatted Code
[fslideshow:14 width:225 src:orig delay:5]

の一文を入れて保存。(テキストそのままと、ソースの両方で編集保存を試しましたが結果は同じでした)
作成した静的ページを表示すると、
スライドショーテストという文字の下に、getadobeflashplayerというアイコンが表示されているだけのページが出てきます。
ちなみに、サイトにフラッシュプレイヤーを実装する予定はありません。

質問2.デモサイト(https://demo.geeklog.jp/mediagallery/album.php?aid=1&page=1)の4) セクションで囲まれない部品タイプのsub-slideshow-fadeを再現しようとしましたが、再現できません。
試した方法
静的サイトで新規作成、内容に、下記を入力保存
PHP Formatted Code
[medialist:14 src:orig theme:sub-slideshow-fade animation:scale limitcnt:3 animation:fade autoplay:true autoplayinterval:7000 draggable:true easing:ease finite:true pause-on-hover:true index:0 velocity:1 rate:16_9 minheight:400 maxheight:500 animationduration:0.1s]

結果、medialist14にアップしている3枚の画像が、縦一列で一度に並んで表示されます。demoのようなスライダー表示になりませんし、下の丸いボタンも出ません。

その他
何度かエラーが出ました。
Table '*****.gl_mg_config' doesn't exist in *****/private/plugins/dataproxy/drivers/mediagallery.class.php:49. SQL in question: SELECT config_value FROM gl_mg_config WHERE (config_name = 'loginrequired'Wink
この開発環境のGLのバージョンは2.1 ,メディアギャラリーは1.7.0, Dataproxyは2.1.1 です。
エラーは1、2回出た後は出てないので、もしかしたらアップグレード前の古いキャッシュを誤認していたのでしょうか?
それとも、GLとメディアギャラリーとDataproxyのバージョンが合っていませんか?gl_mg_configというテーブルは実際存在してません。

dataproxyプラグインを一時的にオフにしても、質問1、2のような症状になりました。

以上のような具合です。
アドバイスよろしくお願いします。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5932
場所:Tokyo
documentにも添付しておりますように、アルバムのスライドショーなどの自動タグは、[ medialist です。
fslideshowは、メンテナンスしていませんので、medialistをご利用ください。

詳しくはアルバムを表示していただくことで、自動タグの書式、事例をご確認ください。


https://www.geeklog.jp/mediagallery/album.php?aid=10&page=1
このなかで、たとえば
1section-slideshow
をご利用ください。

PHP Formatted Code
【medialist:10 src:orig theme:1section-slideshow limitcnt:10 src:disp dotnav:1 animation:fade】

  • ボタン

    ボタン

    神代植物公園で撮影しました。(2015/5/2)
  • シャクナゲ

    シャクナゲ

    神代植物公園で撮影しました。(2015/5/2)
  • フジ

    フジ

    神代植物公園で撮影しました。(2015/5/2)
  • ハンカチノキ

    ハンカチノキ

    神代植物公園で撮影しました。(2015/5/2)
  • トチノキ

    トチノキ

    神代植物公園で撮影しました。(2015/5/2)
  • なんじゃもんじゃ

    なんじゃもんじゃ

    深大寺で撮影しました。(2015/5/2)
  • 麝香藤

    麝香藤

    良い香りがします。


    状態: オフライン

    OMAL

    Forum User
    Active Member
    登録日: 02/14/18
    投稿数: 59

    このなかで、たとえば
    1section-slideshow
    をご利用ください。

    PHP Formatted Code
    【medialist:10 src:orig theme:1section-slideshow limitcnt:10 src:disp dotnav:1 animation:fade】



    このコードを試したら、下記エラーがブラウザのコンソールに出ました。これまでの試行でも似たようなエラーが出てました。
    このコードも前回同様、アルバムの画像が縦一列に崩れて全部表示されるアウトプットになりました。

    Uncaught ReferenceError: swfobject is not defined at index.php?page=******:302

    <!-- begin pathtogeeklog/plugins/mediagallery/templates/fsat.thtml -->


    var flashvars = {};
    var params = {
    wmode: "transparent"
    };
    var attributes = {};

    flashvars.action="true";

    flashvars.xmlUrl="pathtopublichtml/mediagallery/xml.php?aid=14%26src=orig&amp;showDropShadow=true&amp;delay=5&amp;transInType=Fade&amp;transOutType=Fade&amp;noLink=false&amp;showControls=true";
    swfobject.embedSWF("pathtopublichtml/mediagallery/players/minislideshow.swf", "mms13075", "225", "168.75", "9.0.115.0", "expressInstall.swf", flashvars, params, attributes);


    <a href="http://www.adobe.com/go/getflashplayer">

    </a>


    <!-- end pathtogeeklog/plugins/mediagallery/templates/fsat.thtml -->

    メディアギャラリーのどこかの設定を変更しないといけないのでしょうか?アドバイスお願いします。

    それと、このプラグインにデバッグモードみたいなのは付いていませんか?付いているなら教えてください。

    状態: オフライン

    OMAL

    Forum User
    Active Member
    登録日: 02/14/18
    投稿数: 59
    上の投稿が編集も削除もできなくなっているので追加で投稿します。
    上の投稿の訂正ですが、
    swfobjectのエラーは別の箇所にブロックで埋め込んでいたコードが吐いていたものでした。fslideshowは使用非推奨とのことでしたのでそちらは無視してもらっていいです。

    ブロックをオフにして、再度見てみたら、エラーはブラウザからもサーバーのログにも出ていませんでした。
    表示されるページの内容は、前に書いている通り、そのアルバムの画像が縦に並んで表示されています。また、その一番最初の画像の上に高さ200px弱の隙間ができています。吐き出されているタグを見てみると、div id="modal-1" uk-modal="" というもののようです。そのdivタグの中身はコードは色々吐かれていますが、ブラウザ表示は空白です。200四方の隙間が表示されている感じです。

    どこかの設定がまずくて、jsやスタイルシートが機能してないのではないでしょうか?設定の方法を教えてください。

    それともGL2.1というのがまずいのでしょうか?GL2.2の本番環境を直接触って試してみるのは1週間後くらいになります。
    または、メディアギャラリーを使う前提に別のプラグインのインストールが必要とかあるのでしょうか?

    状態: オフライン

    Ivy

    Site Admin
    Admin
    登録日: 01/01/04
    投稿数: 5932
    場所:Tokyo
    このメディアギャラリーは、UIkit v3のスライドショーを活用しています。
    UIkitのバージョンを確認してください。

    fsat.thtmlは、使っていないので、間違って使ってもエラーにならないよう、テンプレートの中身を削除するとよいですね。

    実際のURLをみたら原因がわかりますので、よろしければメールでご連絡ください。

    状態: オフライン

    OMAL

    Forum User
    Active Member
    登録日: 02/14/18
    投稿数: 59
    メールさせていただきました。
    回答よろしくお願いします。

    状態: オフライン

    Ivy

    Site Admin
    Admin
    登録日: 01/01/04
    投稿数: 5932
    場所:Tokyo
    やはり UIkit v2 が使われていますね。
    v3を使ってください。
    最新Geeklogのdenim_three やivywe版のdefaultでは、v3を使っていますのでどうぞ。

    ivywe版に同梱しているMediaGalleryは、ivywe版のGeeklogのテーマdefaultで活用することを前提に、UIkit v3 で動きます。
    あるいは、 Geeklog本家開発版2.2.1 テーマdenim_threeで動きます。
    v2 v3 でかなり文法が違うのです。

    状態: オフライン

    OMAL

    Forum User
    Active Member
    登録日: 02/14/18
    投稿数: 59
    うーん、すでにdenimベースでサイトのテーマをカスタマイズしてしまっているので、私の環境で今からv3を使うのは難しいです。

    質問ですが、medialistが使えないバージョンのメディアギャラリーで画像一覧を表示することはできないのですか?公開サイト上でスライドは動くようですが公開サイト上で画像一覧の表示方法が分かりません。

    ページナビゲーション

    時刻はすべて JST , 現在の時刻は 09:58 PM

    • 通常
    • 注目トピック
    • ロック済
    • 新着
    • 注目トピック 新着
    • ロック済トピック 新着
    •  ゲストユーザの投稿を見る
    •  ゲストユーザ投稿可能
    •  一部のHTMLを許可
    •  バッドワードをチェック