2019/07/22 20:53 JST

Geeklog Japan Forums

index.phpが表示されない

ページナビゲーション


状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
tsujibonさん こんにちは。 _sample のファイルに必要なものをセットして _sampleを削除してファイルをアップロードしていただいているでしょうか。 (sampleというのはまぎらわしいなとおもいますが、) sampleのファイルをベースにファイルを修正してください。 エラーメッセージは、表示されるエラーの内容を コピーペーストしてお知らせください。 そうしたらどういう理由でエラーになっているか わかる場合が多いのでお願いします。 また、文字化け、ですが、MySQLとPHPのバージョンはどうでしょうか。 文字コードはUTF-8ですか?EUCですか?

状態: オフライン

tsujibon

Forum User
Active Member
登録日: 02/22/06
投稿数: 37
今駒さん、ありがとうございます。 そうでしたか、sampleファイルを直していけば良かったんですよね。 ぼくはオリジナルのパッケージを基本に、そのファイルを触ってました。 結局、上手く日本語も表示されました。 ただインストールプログラム画面が思いっきり文字化けしてました。 またダメかと思って、index.phpを呼び出したら、正常に表示されてました。 ん~・・・これはどうなんでしょう。 またどこかでトラブルかな? とりあえずできました。ありがとうございました。 またお聞きすることになると思いますので、今後ともよろしくお願いします。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
言語はどれに設定されましたか? MySQLのバージョンはいくつなのでしょう? 不具合があればそのあたりも確認してください。

状態: オフライン

tsujibon

Forum User
Active Member
登録日: 02/22/06
投稿数: 37
言語はconfig.phpではutf-8に設定してますが、 xrea-adminのMySQLの文字コード選択を見てみるとEUC-JPになってます。 選択するにもutf-8がないんです。 バージョンはMySQL5だと思います。 ただインストールプログラム画面が文字化けしてるだけで、 (つまりstep1of2、Step2of2) サイトは文字化けしてません。 問題ないように思うんですが・・・

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
以下の対策はされましたか? https://www.geeklog.jp/article.php/install_condition MySQLのバージョン5.0以上でUTFで使用が可能かと思いますが、 lib-database.phpの最後に次の1行を追加してインストールしてみてください。 DB_query ("SET NAMES 'utf8'" ); ※対策しないでインストールすると、初期に作成される日本語の記事が文字化けしたり、画面より入力する記事が文字化けします。

状態: オフライン

tsujibon

Forum User
Active Member
登録日: 02/22/06
投稿数: 37
lib-database.phpの最後に、 DB_query ("SET NAMES 'utf8'" ); を追加するとエラーになりました。 ----------------------------------------------------- An SQL error has occurred. Please see error.log for details. ----------------------------------------------------- systemの中のlib-database.phpでいいんですよね。 MySQLのバージョンが違うのでしょうか・・・ MySQLはサーバ側にあるものですよね。すみません無知で。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
error.log を見ていただけますか? それと、https://www.geeklog.jp/article.php/install_condition こちらを改めてみていただき、 サーバ: PHP Version: mysql version: register_globals: default_charset: mbstring.language: mbstring.http_output: mbstring.encoding_translation: をご連絡ください。

状態: オフライン

tsujibon

Forum User
Active Member
登録日: 02/22/06
投稿数: 37
サーバ:Server API:Apache PHP Version:4.4.2 mysql version:Client API version:4.0.26 register_globals:On default_charset:no value mbstring.language:Japanese mbstring.http_output:pass mbstring.encoding_translation:Off error.log はどう見るんですか? 同じinfo.phpで見ると、no valueになってます。 よろしくお願いします。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
サーバは、XREAですよね? /private/***/logs/ といったところに error.log, access.log などがありませんか?

状態: オフライン

tsujibon

Forum User
Active Member
登録日: 02/22/06
投稿数: 37
そうです、XREAです。 error.logはこれですかね。 ---------------------------------------------------- *** dummy entry *** Tue Jun 6 14:53:20 2006 - 1193: Unknown system variable 'NAMES'. SQL in question: SET NAMES 'utf8' Tue Jun 6 23:22:35 2006 - 1193: Unknown system variable 'NAMES'. SQL in question: SET NAMES 'utf8' ----------------------------------------------------- お手数おかけしますが宜しくお願いします。

ページナビゲーション

時刻はすべて JST , 現在の時刻は 08:53 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック