2021/05/10 14:54 JST

Geeklog Japan Forums

メール記事投稿ができない

ページナビゲーション


状態: オフライン

せいち

Forum User
Newbie
登録日: 2006/05/25
投稿数: 13
せいちです。 今回ご質問したいのは件名のとおりです。 メール記事投稿ができなくて困っています。 自分はXreaでサーバーをレンタルし、現在フォーラムの設置までは 問題なく完了しておりますがメール記事投稿ができません。 手順 ■1 geeklog.jp にあるとおりの設定を行い ■2 「投稿メール受信」をクリックしました 現象 Xreaの提供しているSquirrelMailでは無事受信できています。 その後「投稿メール受信」をクリックすると SquirrelMailからメールが消えますが記事投稿は完了していません。 ■1 以下のプログラム構成に設定し /private/geeklog/system/custom/  custom_photomail_ini.php  custom_photomail.php custom_mail.php  layout/photomail/ photo_thumb_yes.thtml  layout/photomail/ photo_thumb_no.thtml 以下の修正を行い custom_photomail_ini.php修正箇所: 18: $this[host] = "s000.xrea.com"; //メールのPOP3サーバー名 19: $this[user] = "hoge@hoge.com"; // ユーザーID 20: $this[pass] = "hogehogehoge"; // パスワード 52: $tida = "NewTopic"; // 話題用IDの既定値 ■2 hoge@hoge.com にメールを送信し、自分のサイトで 「投稿メール受信」を選択しても記事が投稿されません。 以上お手数ですがご指導よろしくお願いいたします。

状態: オフライン

Ivy

Site Admin
管理者
登録日: 2004/01/01
投稿数: 5967
場所:Tokyo
投稿メール受信すると、正常なら管理者メニューの「記事」をクリックすると、仮投稿モードで記事が増えています。 これの仮(ドラフト)をはずして話題を選択して公開します。 受信できない場合には、アカウント登録がないメールアドレスからの場合にはいきなり記事にならず、承認リストにはいります。 以上のどちらでもなく、受信できていないでしょうか。 画像ファイルを添付されていますか? 画像ファイルが添付されている場合には、画像サイズが初期設定ファイルの指定より大きいときは無視されて記事になりません。スパム扱いになります。

状態: オフライン

せいち

Forum User
Newbie
登録日: 2006/05/25
投稿数: 13
せいちです。 今駒哲子さん返信ありがとうございます。 アカウント登録が完了しているアドレスからhogehoge.comに メールを送信しましたが、仮投稿にもならず、承認リストにも メール投稿記事が存在していません。 ですが、SquirrelMailからは受信メールが消えます。。 また、画像ファイルは添付していません、通常のテキストのみです。 以上です。

状態: オフライン

Tsuchi

Site Admin
管理者
登録日: 2005/06/03
投稿数: 782
場所:大阪府豊中市
>SquirrelMailからメールが消えますが ということは、 メールの受信はできているが、なんらかの事情で記事が作成されなかった。 ということになります。 >52: $tida = "NewTopic"; // 話題用IDの既定値 ここで修正された話題IDの話題は存在しますか? custom_photomail_ini.php $this[anonymous] = 0;//←ゲストユーザーの投稿を認める時は1にしてください。 のところは、0のままですか? 投稿されたメールアドレスが、ユーザ登録されていないものなら、 この場合、投稿は破棄されます。

状態: オフライン

せいち

Forum User
Newbie
登録日: 2006/05/25
投稿数: 13
Tsuchiさん返信ありがとうございます。 せいちです。 >SquirrelMailからメールが消えますが ということは、 メールの受信はできているが、なんらかの事情で記事が作成されなかった。 ということになります。 その通りだと思います。 どんな可能性があるのかわからず困っています。 >52: $tida = "NewTopic"; // 話題用IDの既定値 ここで修正された話題IDの話題は存在しますか? 存在します。話題用IDはNewTopicで作成しています。 custom_photomail_ini.php $this[anonymous] = 0;//←ゲストユーザーの投稿を認める時は1にしてください。 のところは、0のままですか? 1に設定しています。 ゲストユーザーの投稿は認めております。 以上よろしくお願いいたします。

状態: オフライン

Ivy

Site Admin
管理者
登録日: 2004/01/01
投稿数: 5967
場所:Tokyo
メーラーとか、メールの書式とかの関係でもない・・・でしょうか。 他、記事投稿、コメント、RSS配信などなど、正常なのですね?

状態: オフライン

せいち

Forum User
Newbie
登録日: 2006/05/25
投稿数: 13
Quote by: 今駒哲子

メーラーとか、メールの書式とかの関係でもない・・・でしょうか。 他、記事投稿、コメント、RSS配信などなど、正常なのですね?

メール記事投稿を行っているメーラーは Gmail で メールの書式はテキスト形式のGmailの初期設定(UTF-8?)です。 記事投稿、コメントなどなど初期設定で管理MENUから実行できる機能はすべて正常です。 (RSS配信は確認できていません、確認します) いまだ解決できません Geek 以上です。

状態: オフライン

Tsuchi

Site Admin
管理者
登録日: 2005/06/03
投稿数: 782
場所:大阪府豊中市
Gmailって誰かに招待とかしてもらわないと使えなかった? UTF...このあたりがあやしいですが、 とりあえず、メーラ変えてみてください。 携帯で送るとか、Outlookとか、Al-Mailとかとか

状態: オフライン

せいち

Forum User
Newbie
登録日: 2006/05/25
投稿数: 13
Quote by: Tsuchi

Gmailって誰かに招待とかしてもらわないと使えなかった? UTF...このあたりがあやしいですが、 とりあえず、メーラ変えてみてください。 携帯で送るとか、Outlookとか、Al-Mailとかとか

せいちです。お返事ありがとうございます。 メーラーを変えて試して結果を報告いたします。 取り急ぎ連絡まで。

状態: オフライン

Tsuchi

Site Admin
管理者
登録日: 2005/06/03
投稿数: 782
場所:大阪府豊中市
Gmail アドレス作ったので、近々試してみます。

ページナビゲーション

時刻はすべて JST , 現在の時刻は 02:54 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック