2019/06/18 10:30 JST

Geeklog Japan Forums

ブラウザの種類とログインできない問題


状態: オフライン

agunas

Forum User
Newbie
登録日: 01/27/11
投稿数: 3
少々お聞きしたいことがあって掲示板に投稿させてもらいます。 タイトル通りGeeklogを導入してログインしようとおもったら ログインできない現象が発生しました。 しかし、ログインできるブラウザもあればできないブラウザもあり 原因が全く分かりません。 ログインできるブラウザ FireFox 3.6.13 IE7 ログインできないブラウザ Safari google chrome 8.0.552.237 ブラウザの設定だと思いますがどこを修正すれば可能になるのかがわからず・・・。 キャッシュも削除しましたがログインすることはできませんでした。 なんとか解決したいのでよろしくお願いします。

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
おはようございます。 ログインできないブラウザのCookieの設定を確認してみてください。 Cookieを保存しないような設定になっていませんか? 今MacのSafariで確認してみたところ、環境設定-セキュリティ-Cookieの受け入れを 受け入れないにしたところ、たしかにログインできませんでした^^ ちなみにSafariでは私は普段訪問したサイトからのみ受け入れるでログインできていました。

状態: オフライン

agunas

Forum User
Newbie
登録日: 01/27/11
投稿数: 3
Quote by: yoshi_2008おはようございます。 ログインできないブラウザのCookieの設定を確認してみてください。 Cookieを保存しないような設定になっていませんか? 今MacのSafariで確認してみたところ、環境設定-セキュリティ-Cookieの受け入れを 受け入れないにしたところ、たしかにログインできませんでした^^ ちなみにSafariでは私は普段訪問したサイトからのみ受け入れるでログインできていました。
おはようございます。 情報ありがとうございます。 早速「普段訪問したサイトからのみ受け入れる」という設定で Cookieを削除してからアクセスを試みましたがログインできませんでした。 後気付いたことがあるのですが、Geeklogの公式(この掲示板のこと)にはSafariでログインできました。 ブラウザの設定じゃなくて別の問題のような気がしてきました・・・ Frown

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
後気付いたことがあるのですが、Geeklogの公式(この掲示板のこと)にはSafariでログインできました。 ブラウザの設定じゃなくて別の問題のような気がしてきました・・・ Frown
以前Geeklogの設定を色々触っていた時に、コンフィギュレーション-その他-セキュアなクッキーを「はい」にしたためにサイトへログインできない状況になったことはありますが、試していないのでわかりませんが、おそらくすべてのブラウザでログインできなかったと思います。 一部のブラウザでログインできないんですよね…う~む… すみません、役に立ちませんで…また何か思いついたら書き込みます^^

状態: オフライン

agunas

Forum User
Newbie
登録日: 01/27/11
投稿数: 3
自己解決しました。 名前解決の問題でした。 諸事情でDNSサーバにサーバ名を登録できないので IPアドレスで直接アクセスしてたんですけど IPのみだとCookieがうまく動作しないようです。 あまりやりたくない手法ですがクライアント(Vista)のhostsファイルに IPアドレスとサーバ名を追記したところCookieが作成されるようになり ログインすることができました。 本来ならDNSサーバに登録できれば今回のような事態にならなかっただろうと思います。 ご迷惑をおかけしました。

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
DNSは構築すればずいぶん楽になりますよね。 もしもNTT光ならルーターのローカルIPアドレスが192.168.24〜なのでご注意を。 意外とこんなところでひっかかります(経験談) とにかく問題は解決できたようで何よりです Razz

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
ドメインの情報に問題があると,セキュリティートークンエラーでひっかかってログインできなかったかとおもいます。 たとえば, /admin/install/info.php を実行して Hostname: Portがただしいドメインになっていないとログインできません。

状態: オフライン

terayama

Forum User
Active Member
登録日: 02/16/07
投稿数: 218
xampp-win32-5.6.11-1-VC11-installer
geeklog-2.0.0-jp-extended-1.0.tar
でローカル運用してみました
192.168.24.62 固定IPだと同様の結果
 Firefox と IE はログイン可
 Chrome Sleipnir はログイン不可
ブラウザの設定をいろいろ試してみましたがだめでした
ブラウザの仕様とあきらめるしかなさそうです
元記事にあるように hosts ファイルを設置すると問題なくログインできます
Geeklogのクッキードメイン他を192.168.24.62のままだとChromeはログインできません

Xamppだと日付関係で文字化けします
一応の対策を別スレッドに書いておきます

Quote by: agunas

少々お聞きしたいことがあって掲示板に投稿させてもらいます。

タイトル通りGeeklogを導入してログインしようとおもったら
ログインできない現象が発生しました。
しかし、ログインできるブラウザもあればできないブラウザもあり
原因が全く分かりません。

ログインできるブラウザ
FireFox 3.6.13
IE7

ログインできないブラウザ
Safari
google chrome 8.0.552.237

ブラウザの設定だと思いますがどこを修正すれば可能になるのかがわからず・・・。
キャッシュも削除しましたがログインすることはできませんでした。
なんとか解決したいのでよろしくお願いします。


状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
現状検証はすべてサーバーで行っていますので、サーバーにインストールしてお試しください。
開発版(GitHub)およびIVYWE版はGeeklog 2.1で提供しています。

時刻はすべて JST , 現在の時刻は 10:30 AM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック