2019/03/22 01:08 JST

Geeklog Japan Forums

1.8にアップグレードしたサイトがSecurity Tokenエラーになる原因はテーマの変更漏れ


状態: オンライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5893
場所:Tokyo
特定サイトの特定テーマで、Security Tokenエラーになる現象を調査していましたが、原因が特定できました。 header.thtml は、1.8.0から以下の行がすべて不要になりますが、特に、{css_url}をリンクする行が消されていないと、なにを編集してもSecurity Tokenエラーになります。新規インストールでは問題はでませんが、1.7以前からのアップグレードで、header.thtmlの変更漏れがあると発生しますので注意してください。
PHP Formatted Code
<link rel="stylesheet" type="text/css" href="{css_url}" title="{theme}"{xhtml}>

{advanced_editor}
<!-- Load Common Javascript Libraries -->
<script type="text/javascript" src="{site_url}/javascript/common.js"></script>
<script type="text/javascript" src="{layout_url}/javascript/confirm.js"></script>
<script type="text/javascript" src="{layout_url}/javascript/fix_html.js"></script>

時刻はすべて JST , 現在の時刻は 01:08 AM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック