ようこそ! Geeklog Japan 2019/01/18 12:23 JST


 2011/12/09 03:50 JST (参照数 4147回)  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 01/01/04
投稿数: 5855
場所:Tokyo
アップグレードしたとき コンフィギュレーション( /admin/configuration.php )が 以下のようなエラーをはくことがあります。
PHP Formatted Code
2 - array_key_exists() expects parameter 2 to be array, null given @ /****/geeklog/system/classes/config.class.php line 1685
これは、どうやら古くてconfigurationに対応していなかった時代のプラグインが 存在しているとき、アップグレードすることにより、本来つくられてはいけないデータが gl_conf_value につくられて、それでエラーが起きるようです。 以下の2つをDBから消せばOK。
PHP Formatted Code
`gl_conf_values`:
('sg_main', 'N;', 'subgroup', '<old plugin>', 'N;', 0, -1, 0, NULL, 0),
('fs_main', 'N;', 'fieldset', '<old plugin>', 'N;', 0, -1, 0, NULL, 0);
未対応プラグインをアップグレードしたことによるものですが、エラーが出ないように アップグレードのスクリプトを修正できればよいですね。

時刻はすべて JST , 現在の時刻は 12:23 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  • ゲストユーザの投稿を見る 
  • ゲストユーザ投稿可能 
  • 一部のHTMLを許可 
  • バッドワードをチェック