2019/03/21 10:26 JST

Geeklog Japan Forums

1.8拡張版をインストール出来ない 修正

ページナビゲーション


状態: オフライン

toshiaf

Forum User
Regular Member
登録日: 02/20/12
投稿数: 21
最初、wkyGeeklog インストラー Ver 2.4.12.0 を利用しインストールを試みました。 ところが、このプログラムが途中で ファイルをアップロードしています(テーマ領域) を表示している最中にプログラムが止まって しまいます。 PC環境は Windouws7 32 bit 環境 そこで、preinstallcheck.phpで環境はOKであることを 確認し、Step4のDB環境を設定し、インストール。 DBの中にテーブルを50個作ったのは、確認したのですが、 その後に Unfortunately, an error has occurred rendering this page. Please try again later. のメッセージを表示し、止まってしまいます。 インストールされるべきアドレスをブラウザでクリックすると 白紙が表示されます。 あと、Siteconfig.php にある $_CONF['path'] = '/path/to/Geeklog/'; $_CONF['path_system'] = $_CONF['path'] . 'system/'; $_CONF['default_charset'] = 'utf-8'; $_CONF_FCK['imagelibrary'] = '/images/library'; のぶぶんですが、 これはどのパスを指定すべきなのでしょうか? 雰囲気的には、絶対パスのPrivate の部分ではと思って 試してみましたが、同じエラーが出ています。 それ以外にも修正スべきところは、指摘して頂ければ助かります。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5892
場所:Tokyo
wkyGeeklog自動インストーラで、接続が途中でとまる例はあまりないのですが、サーバによって、タイムアウトの関係でとまるのかと思います。 サーバにただしくソースがアップロードされていない。おそらくテーマファイルあたりで止まっています。 手動で、パッケージをダウンロードして、アップロードしてください。 パスは手動で、サイトを表示したときインストーラに遷移。パスのサジェスチョンが出るのでそれでインストールしてみてください。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5892
場所:Tokyo
Siteconfig.php は、インストーラの指示にしたがってインスチールしたら自動的にかきかわるので、 手動でソースをいじる必要はありません Smile

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5892
場所:Tokyo
いまでは手動でのインストールもすごく簡単になっています。 1.ファイルを、非公開、公開(public_html以下)に分けてアップロード。 2.ブラウザをたちあげてドメインを表示 3.画面にしたがってインストール これでおしまいです。 module版PHPならパーミッション設定が3のステップで要求されるのですが、CGI版PHPならその作業も不要です。 自動インストーラを利用すると、1,2と、3で要求されるパーミッションの変更が不要になる、ということになります。

状態: オフライン

toshiaf

Forum User
Regular Member
登録日: 02/20/12
投稿数: 21
回答ありがとうございます。 さて、ファイルを手動でアップロードして、 http://www.XXX.com/Jpn/admin/install/index.php 起動すると、下記エラーメッセージが出ました。 ------------------- error msg start -------- Warning: require_once(/private/geeklog/system/lib-database.php) [function.require-once]: failed to open stream: No such file or directory in /home1/XXXX/public_html/XXX.com.www/Jpn/admin/install/index.php on line 430 Fatal error: require_once() [function.require]: Failed opening required '/private/geeklog/system/lib-database.php' (include_path='.:/usr/lib64/php:/usr/lib/php:/usr/share/pear') in /home1/XXXX/public_html/XXX.com.www/Jpn/admin/install/index.php on line 430 ------------------- error msg start -------- どうやら、include pathの設定がおかしいように思いますが、これはどこで設定しているのでしょうか?

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5892
場所:Tokyo
/private/geeklog/system/lib-database.php が無い、というエラーですが、このファイルはサーバにただしくアップロードされているでしょうか。 サーバはどのサーバーでしょうか。 FTPは、FileZillaかNextFTPを使ってください。その他のFTPソフトでは送信もれなど問題が起きる場合があります。(大量のファイル送信で安心できるFTPソフトを使ってください) また、PHP MySQLのバージョンもお願いします。

状態: オフライン

toshiaf

Forum User
Regular Member
登録日: 02/20/12
投稿数: 21
それでは、 http://lightbox.com/photo/v6WGYWH にインストールの時の画面をアップロードしたので、 御覧いただけますか? PHPのバージョンは 5.2.17 前回のメッセージですが、下のエラーメッセージにあるパスが通っていないのが原因とおもうのですが…。 前回は430でしたが、今回は ------------------- error msg start -------- Warning: require_once(/private/geeklog/system/lib-database.php) [function.require-once]: failed to open stream: No such file or directory in /home1/XXXX/public_html/XXX.com.www/Jpn/admin/install/index.php on line 278 Fatal error: require_once() [function.require]: Failed opening required '/private/geeklog/system/lib-database.php' (include_path='.:/usr/lib64/php:/usr/lib/php:/usr/share/pear') in /home1/XXXX/public_html/XXX.com.www/Jpn/admin/install/index.php on line 278 ------------------- error msg start -------- になっています。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5892
場所:Tokyo
ファイルは問題なくアップロードされていたのでしょうか。 /private/geeklog/system/lib-database.php 通常すべてのファイルがただしい位置にアップロードされていれば こういったエラーは出ないのですが Frown

状態: オフライン

toshiaf

Forum User
Regular Member
登録日: 02/20/12
投稿数: 21
結論から言うとファイルを全てアップロードし直して、 インストールをしても一番最初に書いたエラーメッセージ Unfortunately, an error has occurred rendering this page. Please try again later が出ます。 FTP は FileZilla 全部ファイルを削除して、再度アップロード failed transfer は 0 そして再インストール それで、 また Unfortunately, an error has occurred rendering this page. Please try again later のエラーメッセージ 英語ブラウザーでインストールしたので、これが原因かと、 マシンを代え、ディレクトリーを代えて、Public & Privateのファイルを再度全てコピーして、 インストールしても、同じ インストールに利用したのは ・Firrefoxの英語版&日本語版 ・Google Chrom 日本語版 これらでインストールしても同じ下記エラーが Unfortunately, an error has occurred rendering this page. Please try again later のエラーメッセージ エラーがでたので、期待しないでサイトへアクセスすると 文字化けしながら表示するので、 XXX.com ← コレを英語サイトに XXX.com/Jpn ←コレを日本語サイトに と考えてインストールしましたが、 最初 XXX.com/Jpn で表示していても、 いつの間にか /Jpn 抜きのurlが表示されました。 なので、どうやら システムの部分を GeeklogEng Jpnとか 分離しないとダメそうですね。 そして日本語に表示を切り替えは出来たのですが、 日本語で記事投稿するとタイトルに????が とうぜん、記事にも????? で、日本語表示はダメです。現在のところですが。 結局、一番最初に書いた Unfortunately, an error has occurred rendering this page. Please try again later このメッセージが出力される理由ってなんでしょうか? それが知りたいです。 あと、システムの諸元ですが、 Host server OS: linux cpsrvd 11.30.5.6 MySQL client version: 5.1.60 PHP version 5.2.17 MySQL version 5.1.60-community-log Server: Localhost via UNIX socket Protocol version: 10 User: XXXXXXXXXXXXXXXXXXX MySQL charset: UTF-8 Unicode (utf8) です。何かおかしいと事ありますか?

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5892
場所:Tokyo
パッケージの展開はなにを利用されているでしょうか。 ExpLZHでしょうか。 他の、展開ソフトではただしく展開されないケースがあります。 そもそも自動インストーラでエラーが出る というのはいままでそういった事例がないのですが、サーバはどこのサービスをご利用でしょうか。自動インストーラでパス設定ミスでエラーになるケースを除いて、ですが。接続も切れないよう頻繁にチェックを追加したりしていたはずなんですが。 Unfortunately, an error has occurred rendering this page. Please try again later これですが、error.log はなにか書き込まれていないでしょうか? インストーラ/admin/install/ で日本語に切り替えて、インストールしていただいているでしょうか。 インストールできたあと、その画面になるのでしょうか。 だとしたら、 /public_html/siteconfig.php の $_CONF['site_enabled'] = true; の下に $_CONF['rootdebug'] = true; を追加すると、ログインしていない管理者にもエラー内容が表示されます。 パッケージを、ディレクトリ構造そのままに、公開領域以下にアップロードしたら、db-config.phpのパス指定をする必要も無くすぐにインストールできます。 そのかわり非公開領域にアップロードすべきソースも公開領域に展開され、公開TOPのパスにpublic_htmlがついてしまうのですが、テストでインストールするだけならそれで充分で、あとから緊急レスキューツールをつかって移動させることも可能です。 最終手段としてそうしてとにかくインストールは可能かと・・・

ページナビゲーション

時刻はすべて JST , 現在の時刻は 10:26 AM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック