2019/06/20 20:31 JST

Geeklog Japan Forums

Geeklog2.0.0へのfaqプラグインのインストール

ページナビゲーション


状態: オフライン

yuru

Forum User
Active Member
登録日: 04/25/07
投稿数: 206
Geeklog2.0.0へfaqプラグイン 日本語調整版 for Geeklog1.5 and 1.6(バージョン: 1.1.0jpr2)をインストールしようとすると An error has occurred: This is being displayed as "Root Debugging" is enabled in your Geeklog configuration. If this is a production website you must disable this option once you have resolved any issues you are investigating. 256 - An SQL error has occurred. Please see error.log for details. @ ~/system/databases/mysqli.class.php line 279 とエラーになります。 Geeklog2.0.0では使えないのでしょうか?

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
Faq pluginは今は使わず、汎用的に設計できるDataBoxを活用しているので、そちらに乗り換えていただけばと思います。 自由なタイプのカスタムフィールドが使えます。 カテゴリ表示もできます。 他、jtbhawaiitravel.com, jtbhawaiimice.com,life-time.comなどなど、最近のサイトにはほぼすべてBoxシリーズを活用しています。 https://www.geeklog.jp/databox/category.php/addon_DataBox/code ダウンロードは http://www.ivywe.co.jp 姉妹プラグインにUser Profileとして活用する UserBoxも。 2.0.0でブロック、話題、記事でテーブル構造が変わったため、ほとんどのプラグインで使えなくなり、要望のあったプラグインはこれまですべて2.0.0に対応させていましたが、特に報告のないプラグインは確認できておらず、動かない可能性があります。

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
cold
FAQプラグインではないのですが...同じようなことなのでこちらへ質問させてください。 Paypalプラグイン 銀行振込対応 日本語版も2.0.0へは×でしょうか... error.logへは以下のエラーが出ています。
- Attempting to install the 'paypal' plugin - Attempting to create 'Paypal Admin' group - Attempting to create 'Paypal User' group - Attempting to create 'Paypal Viewer' group - 1054: Unknown column 'tid' in 'field list' in /admin/plugins.php:1144. SQL in question: INSERT INTO gl_blocks (is_enabled, name, type, title, tid, blockorder, content, onleft, phpblockfn, owner_id, group_id, perm_owner, perm_group) VALUES (1,'cart_block','phpblock','Cart','all',1,'',0,'phpblock_paypal_cart',2,45,3,3)
geeklog本体を2.0.0からダウングレードってできましたでしょうか? また、paypalプラグインを動作させるにはどのバージョンが良いでしょうか?

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
Paypal plugin の最新版は2.0対応ですよ。 http://geeklog.fr/shop/index.php

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
早々にありがとうございます! サイトが稼働しているわけではなく、実用に耐えうるかのテスト段階ですので1.8で再インストールすることにしました。Paypalプラグイン自体の動作確認もできていませんので…(^^:

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
http://www.geeklog.fr このサイトでは、いろいろなプラグインやテーマをPaypalプラグインを活用して販売していますから、Paypalプラグインはいつも最新版には応しますよ。

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
Ivy 様 お忙しいところ、ありがとうございます。
Quote by: Ivy

http://www.geeklog.fr このサイトでは、いろいろなプラグインやテーマをPaypalプラグインを活用して販売していますから、Paypalプラグインはいつも最新版には応しますよ。

上記理解しております。 既に2.0.0で本体がインストール済みで、あとからPaypalをインストールする場合に問題があるようで、プラグイン対応リストを見ていますとFAQとPaypalとMultiがNoとなっています。 FAQとPaypalについては注意書きがあり([1][2])、以前のバージョンからアップグレードの場合、FAQおよびPaypalプラグインが既に前バージョンでインストールされていれば問題ないと私は解釈したのですが… したがってPaypal 1.4.3Proを購入してインストールするよりも本体を1.8でインストールし、Paypalプラグイン 銀行振込対応 日本語版の挙動を確かめたのち(←これが検証できていません)、本体をバージョンアップするほうがよいと判断しました。Paypalプラグイン 銀行振込対応 日本語版を使いたいわけですので…

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
プラグイン対応リスト はどこにあるでしょうか。URLをおしえていただけますでしょうか。 Geeklog 2.0.0に対応しているなら新規にプラグインをインストールできないわけがありませんし、そのようなBUGは経験がありません。 プラグイン対応リストによっては、プラグインの対応状況を反映が遅くなっているページもあるかとおもいます。 インストールエラーがある場合には、エラー内容をご連絡ください。

状態: オフライン

yoshi_2008

Forum User
Active Member
登録日: 02/12/08
投稿数: 31
Ivy 様 お世話になります。下記URLを読みました。 http://geeklog.fr/staticpages/index.php/Geeklog_2.0
Geeklog 2.0.0に対応しているなら新規にプラグインをインストールできないわけがありませんし、そのようなBUGは経験がありません。
これは当方では試していません。1.4.3Proが2.0.0に対応しているということでURLを教えていただきましたが、そのページには2.0に対応している記述が見当たらないので購入までいけずにおります。 整理しますと、  ・当方のgeeklog本体は2.0.0  ・Paypalプラグイン 銀行振込対応 日本語版を試したいが   プラグインをインストールする際にエラーが出た。  ・1.4.3ProのURLを掲示板でご教授いただいたが2.0.0対応かどうかわからず。  ・教えていただいたURLにPaypal 1.4.3というものがあるがこちらもエラーが出た。  ・List of plugins for Geeklog 2.0記載のページを発見、旧バージョンからいけば   問題ないと書いてあるように解釈。   ↓現在試し中↓  ・geeklog1.8ならPaypalプラグイン 銀行振込対応 日本語版をインストールできそう。 となります。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5907
場所:Tokyo
もうじき2.1が出ますが、2.0未満と、2.0は話題関係で大きな仕様変更があるので、 今から開発するのであれば、もうほぼテーブル設計は変更がないだろうから、 本家から最新2.1 nightballをダウンロードして自己責任にて2.1正式版にUP(update.sqlをみて差分をphpMyAdminで実行、最新ソース上書き)して公開していただくか、2.0正式版活用をお勧めします。 2.0でPaypalプラグイン最新版が動かないわけはないので。 2.0で2.0非対応の古いPaypalプラグインは動きません。 >旧バージョンからいけば問題ない これはどういう意味なのでしょうか。 2.0では話題関連で大きな変更があるので、話題のID tid がどうの・・・といった SQLが出ることがありますが、それはすべて2.0非対応プラグインを活用しているせいです。

ページナビゲーション

時刻はすべて JST , 現在の時刻は 08:31 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック