ようこそ! Geeklog Japan 2019/01/16 21:02 JST


 2017/03/13 12:01 JST (参照数 1841回)  

状態: オフライン

abc

Forum User

Active Member
登録日: 04/28/07
投稿数: 142
こんにちは 1.4の古いサイトをリニューアルするために、 geeklog-ivywe-Geeklog2.1.2 をインストールさせていただきました。 データベースの書き換えやプラグインがらみでアップデートがうまく行かず、 結局2.1.2を上書きでインストールし、修正したデータベースを読み込んで動作できました。 (記事関係は問題なかったのですが、静的ページは内容を結局コピペで再登録しました) 原因はどうかわかりませんが、 古いバージョンでは各ページにも表示されていた、編集用のエンピツマークが表示されない状態です。 デモサイトが止まっているようなので確認できないのですが、 2.1.2では対応していないのでしょうか?

 2017/03/13 15:24 JST  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 01/01/04
投稿数: 5855
場所:Tokyo
インストールありがとうございます。
エラーメッセージがあると、どのプラグインでエラーになっているかがわかり、/admin/install/rescue.php で、プラグイン無効にして原因をさがせます。

アイコンが動かないのは、fontsへのリンクエラーになっているためで、functions.php の etag をfalseにすると動きます。(昨日ivywe版でコミットしたところでした。)
デモサイトは ただいま準備中で、http://demo.geeklog.net/ しばらくは本家のデモサイトをご利用ください。

 2017/03/13 15:50 JST  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 01/01/04
投稿数: 5855
場所:Tokyo
先ほど、デモサイトをPHP7の環境で設置しました。どうぞご利用ください。

 2017/03/13 19:04 JST  

状態: オフライン

abc

Forum User

Active Member
登録日: 04/28/07
投稿数: 142
Quote by: Ivy

先ほど、デモサイトをPHP7の環境で設置しました。どうぞご利用ください。

Ivyさん。いつもお世話になっております。 Geeklog Japan の右上のメニューにある、DEMO日本語 をクリックしても、 Chromeで、「demo.geeklog.jp のサーバーの DNS アドレスが見つかりませんでした。」 のメッセージが出てきます。

 2017/03/13 19:11 JST  

状態: オフライン

abc

Forum User

Active Member
登録日: 04/28/07
投稿数: 142
Ivyさん。 ありがとうございます。
Quote by: Ivy

アイコンが動かないのは、fontsへのリンクエラーになっているためで、functions.inc の etag をfalseにすると動きます。(昨日ivywe版でコミットしたところでした。)

functions.inc は、\plugins\staticpages の中でしょうか? 「etag」が見つからないのですが?

 2017/03/13 19:22 JST  

状態: オフライン

abc

Forum User

Active Member
登録日: 04/28/07
投稿数: 142
テーマエディタプラグインですが、 chrome で保存すると、画面が真っ白になって、保存できません。 IE11では、保存できます。 ログビューワーで見ると、 chromeでは 2017年03月13日 19時13分13秒 - ***.***.***.*** - Themedit: Unknown theme name posted: 2017年03月13日 19時13分13秒 - ***.***.***.*** - Themedit: Unknown file name posted: 2017年03月13日 19時13分20秒 - ***.***.***.*** - THM_str: undefined index: help_# end {templatelocation 2017年03月13日 19時13分20秒 - ***.***.***.*** - THM_str: undefined index: help_copyright_msg 2017年03月13日 19時13分20秒 - ***.***.***.*** - THM_str: undefined index: help_plg_footercode 2017年03月13日 19時13分20秒 - ***.***.***.*** - THM_str: undefined index: help_trademark_msg 2017年03月13日 19時13分23秒 - ***.***.***.*** - THM_str: undefined index: help_# end {templatelocation 2017年03月13日 19時13分23秒 - ***.***.***.*** - THM_str: undefined index: help_copyright_msg 2017年03月13日 19時13分23秒 - ***.***.***.*** - THM_str: undefined index: help_plg_footercode 2017年03月13日 19時13分23秒 - ***.***.***.*** - THM_str: undefined index: help_trademark_msg IE11では、 2017年03月13日 18時58分10秒 - ***.***.***.*** - Themedit: Unknown theme name posted: 2017年03月13日 18時58分10秒 - ***.***.***.*** - Themedit: Unknown file name posted: のみが記録されています。 原因がわかりません。 ご教示願えますでしょうか?

 2017/03/13 19:26 JST  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 01/01/04
投稿数: 5855
場所:Tokyo
テーマ内に、functions.phpがありますのでそれを編集してください。

 2017/03/13 19:27 JST  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 01/01/04
投稿数: 5855
場所:Tokyo
テーマエディタプラグインを一旦アンインストールして、インストールしなおすか、 コンフィギュレーションで、編集できるテーマを現状に則して登録してください。

 2017/03/13 19:42 JST  

状態: オフライン

abc

Forum User

Active Member
登録日: 04/28/07
投稿数: 142
Quote by: Ivy

テーマ内に、functions.phpがありますのでそれを編集してください。

テーマは、denim を使っています。 下記のように、false になっていました。
PHP Formatted Code

    return array(
        'image_type' => 'png',
        'doctype'    => 'xhtml5',
        'etag'       => false, // never set this true. instead use $options['enable_etag'] above.
        'supported_version_theme' => '2.0.0', // support new theme format for the later Geeklog 2.0.0
        'theme_plugins' => 'denim', // Not requred, you can specify compatible theme of template stored with some plugins
        'options'    => $options // Not requred, some options of this theme
    );
 

 2017/03/13 22:07 JST  

状態: オフライン

abc

Forum User

Active Member
登録日: 04/28/07
投稿数: 142
Quote by: Ivy

テーマエディタプラグインを一旦アンインストールして、インストールしなおすか、 コンフィギュレーションで、編集できるテーマを現状に則して登録してください。


テーマエディタプラグインを一旦インストールして、インストールしなおしましたが、結果は同じでした。

ただ、denim以外のテーマ「default」などにして、保存すると、chromeでも保存できました。
何度か試してみて、denim に戻して保存しても大丈夫でしたので、
数回試していると、ふたたび画面が真っ白になりました。

その後、他のテーマにしても動作せず。
一旦ログアウトして、再度他のテーマで正常保存。
denimに戻すとまた真っ白・・・
みたいな感じです。

ちなみに、正常保存した場合も、エラーログは書き出しをしています。

時刻はすべて JST , 現在の時刻は 09:02 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  • ゲストユーザの投稿を見る 
  • ゲストユーザ投稿可能 
  • 一部のHTMLを許可 
  • バッドワードをチェック