2017/12/14 16:58 JST


 2017/12/06 10:40 JST (参照数 72回)  

状態: オフライン

sasabo-

Forum User

Chatty
登録日: 2008/03/31
投稿数: 42
昨日(2017/12/6)ダウンロードしたIVYWE版。
インストール後にプラグインの追加、削除を行うと次のエラーが発生しています。

E_WARNING(2) - array_key_exists() expects parameter 2 to be array, null given @ /パス省略/lib-common.php line 8679

取り急ぎ、手元にある同一バージョンのタイムスタンプが古いと思われるlib-common.phpファイルと入れ替えたところ、期待通りの動作をしています。

 2017/12/06 13:39 JST  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 2004/01/01
投稿数: 5763
場所:Tokyo
ご連絡ありがとうございます。 多言語サイトではエラーが発生しませんが、通常サイトで発生することを確認しました。 修正します。 このlib-common.php ivywe版は、多言語切り替えのバグを修正したバージョンですので、2.1.3のオリジナルのlib-common.phpに差し替えてなんら問題ありません。

 2017/12/07 05:03 JST  

状態: オフライン

Ivy

Site Admin

管理者
登録日: 2004/01/01
投稿数: 5763
場所:Tokyo
https://github.com/ivywe/geeklog-ivywe/tree/Geeklog2.1.3
こちらに修正をコミットしました。

このエラーは多言語サイトでは出ず、気が付きませんでした。ご連絡ありがとうございました。

時刻はすべて JST , 現在の時刻は 04:58 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  • ゲストユーザの投稿を見る 
  • ゲストユーザ投稿可能 
  • 一部のHTMLを許可 
  • バッドワードをチェック