2019/09/18 18:20 JST

Geeklog Japan Forums

メディアギャラリーの使い方

ページナビゲーション


状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5928
場所:Tokyo
残念ながらUIkit3しかメンテナンスしていません。
(もし UIkit v2にするなら、MediaGalleryのテンプレートをUIkit v2の書式に修正してみてください。
特に、grid関係で、 div class="uk-grid-1-2@m" uk-grid というようなところ、ですね。}

おすすめはやはり、面倒でも、今からdenim_three またはdefaultベースにテンプレートを変更していただくことです。
header.thtml footer.thtml functions.php この3つだけで基本、テーマは変更できます。

状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 53
有難うございます。

状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 53
クリーンインストールした本家gl2.2のテーマをdenim threeにして試したのですが、
下記のスライドショーがうまく表示されません。
https://www.geeklog.jp/article.php/uikit-slideshow
Medialist活用方法紹介ページhttps://www.geeklog.jp/mediagallery/album.php?aid=10でいうと、
5)のlistタイプのuk-list, uk-list_incでサムネイル付きスライドショーの自動タグです。

これを実装すると、上半分のクローズアップ画像の1枚目の画像が空になります。見た目、真っ白の画像です。
吐き出されているコードで見たら、
PHP Formatted Code
<li class="uk-active uk-transition-active" style="z-index: -1;"></li>
でした。
で、下半分のサムネイルの1つ目がこの空画像にリンクされていて、2つ目のサムネイルが1つ目のサムネイルのクローズアップ画像にリンクされています。3つ目のサムネイルは2つ目のサムネイルのクローズアップ画像にリンクされています。

どなたか、この不具合の対処法に心当たりがあれば教えてください。
よろしくお願いします。

状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 53
Ivyさん
1日にこの掲示板からメールにて送らせていただいたサンプルURLのトップページに現在denim threeでこのスライドショーを表示しています。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5928
場所:Tokyo
UIkitはできるだけ最新版に差し替えてください。 初期のUIkit 3ではslideshowは動きません。 記事より、アルバムページのサンプルを参考にしてください。

状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 53
uikit3の最新版をダウンロードして差し替えましたが、症状は変わらずです。アルバムページのサンプルを参考にしました。

多分、本家GL2.2のdenim threeでは駄目なのではないでしょうか。

正常に動いているデモページのソースコードを開いて、関係ありそうなところを丸ごとコピーしてそれを強引に私がテストしてるスライドショーページに追加したら、正常に動くので、詳しく調べて行ったら動かし方が分かると思います。
時間ができたらやってみます。

状態: オフライン

OMAL

Forum User
Active Member
登録日: 02/14/18
投稿数: 53
削除

ページナビゲーション

時刻はすべて JST , 現在の時刻は 06:20 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック