2021/06/25 07:23 JST

Geeklog Japan Forums

CKエディタが表示されない


状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 444
Geeklog2.1.3をインストールして、 静的ページを編集しようと思ったのですが、 アドバンストエディタ(CKEditor)が表示されません。 HTMLは表示されます。なので編集できないわけではないんですが。 試しにFCKEditorにすると表示されます。

状態: オフライン

Ivy

Site Admin
管理者
登録日: 2004/01/01
投稿数: 5974
場所:Tokyo
そうなんですか。おかしいですね...

状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 444
staticpageのindex.phpを ver1.7から ver1.6に差し替えたのが原因でしょうか?
インストール時は、ver1.7でしたが、
PHP Formatted Code
Fatal error: Call to undefined function COM_createControl() in /home/hogehoge.jp/public_html/admin/plugins/staticpages/index.php on line 339

というエラーが出てたので、バックアップしていた ver1.6に差し替えたんです。

状態: オフライン

Ivy

Site Admin
管理者
登録日: 2004/01/01
投稿数: 5974
場所:Tokyo
1.6にしたからかもしれません。
COM_createControlのエラーですが、lib-common.phpにCOMの関数はすべてあるはずです。

2.1.3でそのようなエラーは出ていないのでなんともいえません。
Geeklog全体を最新版にしていただければとおもいます。

状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 444
Ivyさん、ありがとうございます。

lib-common.phpを新しいバージョンにすればいけるのかも。
2.2.1にすれば解決するのかもしれないですが、
とりあえずはそれで試してみます。

状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 444
あれから試行錯誤した結果、

自分なりの結論は、Geeklog2.1.3では、staticpageは1.6を使う。
staticpage1.7を使いたければ、Geeklog2.2.1にアップグレード!

ということで、近々Geeklog2.2.1アップグレードのテストしようと思います。
ただ、以前もトライして一応できたんですが、結構大変だったので。

前回、静的ページプラグインでハマってたので、
今度はすんなりアップグレードできるように、また下調べしなくては。

また、いろいろ教えてください。

状態: オフライン

Ivy

Site Admin
管理者
登録日: 2004/01/01
投稿数: 5974
場所:Tokyo
アップグレードは、Geeklogのコアパッケージに付属しているStaticpagesプラグインを使うようにしてください。

失敗しないコツは、アップグレード時に、プラグインをすべて無効に。

サーバーのファイルは、ディレクトリをリネームしてバックアップしておき、
Geeklogコアのパッケージをアップロードしてアップグレード実行(admin/install/)。
そのあと、ivywe版のファイルをアップロード。
ただし、mapsプラグインやuserboxプラグインはPHP7に対応していないのでファイルごと削除。
ログインしてプラグインをひとつひとつインストール。

ですね。

以前のバージョンは、静的ページのアップグレードでよく失敗していたのですが、
今のバージョンはそのバグは取れていると思います。

時刻はすべて JST , 現在の時刻は 07:23 AM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック