2021/05/06 18:25 JST

Geeklog Japan Forums

Downloadプラグインでエラー


状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 434
いつもお世話になります。

Geeklog2.1.3からの2.2.1srにアップグレードしました。
各プラグインも無事インストールできたと思ったのですが、
ダウンロードプラグインで以下の様なエラーがでます。
PHP Formatted Code

E_WARNING(2) - Use of undefined constant ext - assumed 'ext' (this will throw an Error in a future version of PHP) @
 


PHPのver 7.2.28です。

以前、PHP7.1の別サーバーでアップグレードした際には、
特にエラーは出なかったのですが。

状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 434
なんとか自力でクリアできました!

原因は、
php7.2.以降から、変数をちゃんとクォート(''で囲う)しないといけない!
ということでした。

非公開領域/plugins/downloads/include/function.phpの415行目
PHP Formatted Code

$len = strlen(ext);
 


となってるので、

PHP Formatted Code

$len = strlen('ext');
 


にしてあげる。
extを''で囲ってあげれば解決しました。

お騒がせしました。

状態: オフライン

terayama

Forum User
Active Member
登録日: 2007/02/16
投稿数: 258
最新版?Downloads Plugin v1.2.3 では大丈夫そうですね

状態: オフライン

kuro

Forum User
Active Member
登録日: 2010/03/10
投稿数: 434
terayama様、コメントありがとうございます。

Downloads プラグイン v1.2.3があるんですね!
情報ありがとうございます。

時刻はすべて JST , 現在の時刻は 06:25 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック