2019/07/22 21:22 JST

Geeklog Japan Forums

ブロックの新規作成が出来ません


状態: オフライン

Marks

Forum User
Junior
登録日: 05/22/06
投稿数: 5
1.4.0sr3を新規にインストールしました。日本語化パッチを当ててサーバーにアップし正常に起動して喜んだのもつかの間、テーマの切替ブロックを作ろうとしたら、出来ません。[保存]ボタンをクリックしてもブロック管理画面に戻ってしまいます。いろいろと試行錯誤しながら調査したところ、config.php で
 $_CONF['language'] = 'english';
にすると登録できました。しかし
$_CONF['language'] = 'japanese_utf-8';
に戻すと登録できなくなります。編集して保存も出来ません。有効にするのチェックは変更できます。
サーバーのregister_globals は off ですが、この現象には関係ないと思います。
只不思議なのは、自宅のPCにApacheとPHPとMySqlをインストールして同じようにセットアップしたところ、
$_CONF['language'] = 'japanese_utf-8';
でも正常に動作します。サーバーと自宅PCのPHPの環境設定には殆ど違いはありません。
サーバーはXServerで、Apache/2.0.52 (Red Hat) PHP/4.3.9
PCは、Apache/2.0.58 (Win32) PHP/4.4.2 、OSはwindows2000Pro SP4です。
どういった原因が考えられるでしょうか?

状態: オフライン

mystral-kk

Site Admin
Admin
登録日: 03/23/06
投稿数: 1022
場所:福岡県
当てずっぽうなのですが,XServerのmb_string系の設定はどうなっているでしょうか? 特にmb_languageとmb_internal_encoding。それとMySQLのバージョンは何でしょうか?
-- mystral-kk, "Every cloud has a silver lining."

状態: オフライン

shino

Forum User
Chatty
登録日: 05/03/06
投稿数: 17
Quote by: mystral_kk

当てずっぽうなのですが,XServerのmb_string系の設定はどうなっているでしょうか? 特にmb_languageとmb_internal_encoding。それとMySQLのバージョンは何でしょうか?

すいません、私もXserverなので参加させてください。 ↓phpinfo()を使いました。 http://www.alliedsite.com/test001.php レスをいただきましたら、このページは、削除します。 セキュリティ情報垂れ流しですよね(笑)

状態: オフライン

mystral-kk

Site Admin
Admin
登録日: 03/23/06
投稿数: 1022
場所:福岡県
mbstring.http_output = SJIS mbstring.encoding_translation = On となっているのが気になります。文字化けしませんか? 文字化けするようなら, mbstring.http_output = PASS mbstring.encoding_translation = Off にしてみてください。 あと,safe_mode = off とか magic_quote_gpc = on とか,やっかいな設定がありますね。
-- mystral-kk, "Every cloud has a silver lining."

状態: オフライン

shino

Forum User
Chatty
登録日: 05/03/06
投稿数: 17
>mbstring.http_output = PASS >mbstring.encoding_translation = Off >にしてみてください。 ご返答ありがとうございます。 私の方は記事投稿ができなかったのですが、 解決しました!! Marksさんはどうですか?

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
篠原さん、解決してよかったですね^^
Quote by: 篠原勝幸

セキュリティ情報垂れ流しですよね(笑)

こういう場合は、プライベートメッセージPMで設定情報を送るとかする方法もありますよ。 掲示板とPMとうまくくみあわせて使ってくださいね^^

状態: オフライン

Marks

Forum User
Junior
登録日: 05/22/06
投稿数: 5
happy
篠原さん、情報提供ありがとうございました。 今駒さん、適切なアドバイスありがとうございました。 私も mbstring.http_output = PASS,mbstring.encoding_translation = Off にして 解決しました。 現在サイト開設にあたり、色々なCMSをインストールして、動作検証や機能評価をしています。インストールしたのは、Xoops , Geeklog , Word Press , P_Blog , Blogn Plus , Nucleus などです。現在 Word Press にかかっていたのでレスが遅れ、失礼しました。 静的ページを作れるという点で、Word Press もいいかなと思っていたのですが、これはこれでUTF-8でインストールすると文字化けするし、なかなか一長一短で決めかねています。 現在一般的なサイトやブログでは Word Press(EUC)とし、今回うまく解決したのでポータル系は Geeklog で行こうと思っています。 やはり、僕みたいな初心者では当面はサポートサイトに頼るしかありませんからとても助かります。いずれは貢献できる方に廻りたいとおもいますが、いつのことになるか.... それにしてもWindowsネイティブのプログラミングと違い、文字コードの問題が文字化けだけでなく動作そのものに影響するなんてLinuxやスクリプトの世界は大変ですね。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 01/01/04
投稿数: 5917
場所:Tokyo
giggly
Marksさん、解決してよかったですね Big Grin Geeklogは、軽くて多言語対応でハイセキュリティで、表示属性設定でグループ毎に表示コンテンツを指定できるのがよいところなので、ぜひ使っていってください。 またフィードバックやサポートに回っていただける日がたのしみです^^

時刻はすべて JST , 現在の時刻は 09:22 PM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  ゲストユーザ投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック