2022/08/10 05:45 JST

Geeklog Japan Forums

IE6での現象です。


状態: オフライン

yippie7sn

Forum User
Active Member
登録日: 2007/08/14
投稿数: 122
IE6での現象です。 作業環境は、macなのですが、 mac FireFox、Safari windows FireFox、IE6、IE7、Netscape7、Opera9 で検証しております。 今回の構築内容は、ブログ(日記)仕様なので 話題と記事で管理し、 左ブロックは、記事が追加されると、話題の下に記事名が自動で追加されるので、sitemapmenuにて表示。 Topページに静的ページにて、 ページの案内 ------------------ 新着表示(話題1) ------------------ 新着表示(話題2) ------------------ 新着表示(話題3) と言う構成になっております。 新着表示も静的ページにてphpblock_lastarticlesを使用して 表示させたくない話題をそれぞれ選択して、それぞれの話題の新着が表示されるようになっています。 特に問題なく構築、デザイン(professionalCSSベース)出来ているのですが、なぜかwindowsのIE6だけ、左ブロック、新着表示の(話題1)(話題2)がリンクが出来なくなっています。 その他のブラウザは問題なくリンクします。 windows IE6だけ、新着表示(話題3)だけリンクが出来て、ユーザー情報も入力する事も出来ず、ヘッダのサイトTOPへのリンクも出来ません。 サーバーは、いくつかgeeklog環境をインストールして色々試していますので、問題ないかと思いますが… デザインの違いはブラウザによって、違う事はありますが、今回のような現象は始めてなので、どこがIE6に悪いのかが、判定できずにいます。 記事を削除してみたり、話題を削除してみたり、新着表示をなくしてみたり、右ブロックを別メニューに変更したり、phpブロックではなく、ノーマルブロックに変更したりしましたが、リンクがされませんでした。 これまでに、このような現象がありましたでしょうか? また、何か、この現象をIE6で検証する為に方法がありましたら教えて頂けると助かります。 最悪、インストールからやり直してみた方が宜しいのでしょうか? すみませんが、どなたかおわかりになる方がいらっしゃいましたら、教えて下さい。 よろしくお願い致します。

状態: オフライン

yippie7sn

Forum User
Active Member
登録日: 2007/08/14
投稿数: 122
すみません。 自己解決いたしました。 デザイン作業上、IE用のpng画像を読み込むiepngfix.jsを入れてあったのですが、そちらを削除したら、リンクされるようになりました。 ただデザイン上の問題は解決していないので、そちらは、また別に解決しなくてはならないのですが、とりあえず、IE6での現象は、なくなりましたので、ご報告致します。 お騒がせ致しました。

状態: オフライン

maruyo

Forum User
Regular Member
登録日: 2007/09/18
投稿数: 94
pngfix.jsを入れてみてはどうでしょう? 似たようなことをやっているので、こちらなら大丈夫かもしれません http://homepage.ntlworld.com/bobosola/index.htm iepngfixと違うのはCSSで背景に指定した画像には効力が及ばないところと、イチイチclass指定する必要がないので手間いらずってトコです。 画像が伸びてしまう場合にはsizingMethod='image' か sizingMethod='crop'にするようにしてください。 掲示板2.7にはこのスクリプトがあらかじめ入っています。
maruyo=maruyo123 です

状態: オフライン

yippie7sn

Forum User
Active Member
登録日: 2007/08/14
投稿数: 122
maruyo 様 ご教示ありがとうございます。 今回、IIE用のpng画像が、CSSで背景指定になっていまして、おすすめ頂いたjsや他の方法も試して見ましたが、回避する事ができませんでした。 たぶん、image画像などの指定では、問題なく出来るのだと思います。 取りあえず、力技ですが、gif画像をもう一枚用意してIE用に当てる方法で回避致しました。 デザインからすると、png画像できれいに見せたいところですが、今回は、こちらで妥協いたします。 ありがとうございました。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 2004/01/01
投稿数: 5974
場所:Tokyo
実際のサイトを見せていただければなにかわかったかもしれません。次回また試してだめならURLもどうぞご連絡ください。 先日,デモサイトのカメレオンテーマにこの対策がなかったので,cropを指定してうまくいったばかりです LOL

状態: オフライン

yippie7sn

Forum User
Active Member
登録日: 2007/08/14
投稿数: 122
Ivy 様 いつもありがとうございます。 次回、同じ問題が出た時には、URLをお知らせして、ご教示頂きます! カメレオンテーマも使ってみたいので、ダウンロードはしてあるのですが、なかなか手が回らず、まだ動かせずにいます。使って見たいプラグインですので、ぜひ、テスト環境を整えて、使わせて頂きます。 今後ともよろしくお願い致します。

状態: オフライン

Ivy

Site Admin
Admin
登録日: 2004/01/01
投稿数: 5974
場所:Tokyo
カメレオンテーマプラグインのインストールは Wikiを最初にどうぞ!

時刻はすべて JST , 現在の時刻は 05:45 AM

  • 通常
  • 注目トピック
  • ロック済
  • 新着
  • 注目トピック 新着
  • ロック済トピック 新着
  •  ゲストユーザの投稿を見る
  •  投稿可能
  •  一部のHTMLを許可
  •  バッドワードをチェック